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Welcome and Introduction

Aims of the LHEES capacity building workshop

• Understand the adaptability of methodologies to other GIS software

• Provide uniform steps from the Stage 4 methodologies between ArcGIS and QGIS 
so that they can be replicated

• Provide an opportunity for local authority Q&A / feedback
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Summary of LHEES Stages and  
Considerations
• LHEES Considerations 

• LHEES Structure and Stages



LHEES Considerations

No. LHEES considerations Description

Heat decarbonisation

1 Off-gas grid buildings
Transitioning from heating oil and LPG in off-gas 
areas

2 On-gas grid buildings On-gas grid heat decarbonisation

3 Heat networks Decarbonisation with heat networks

Energy efficiency and 
other outcomes

4 Poor building energy efficiency Poor building energy efficiency

5
Poor building energy efficiency as a driver 
for fuel poverty

Poor building energy efficiency as a driver for fuel 
poverty

6
Mixed-tenure, mixed-use and historic 
buildings

Mixed-tenure, mixed-use buildings, listed buildings, 
and buildings in conservation areas



LHEES Structure and Stages

Use of GIS software



QGIS Introduction

• Why QGIS?

• Data Types

• Breakdown of QGIS approaches



• QGIS is a free and open-source cross-platform 
geographic information system (GIS) software that 
supports viewing, editing, printing, and analysis of 
geospatial data.

• Historically most local authorities have used 
ArcGIS for spatial analysis of data.

• However, some local authorities use QGIS. 
• LHEES Stage 4 methodologies were generated for 

use with ArcGIS this presentation shows the 
equivalent steps using QGIS.

• Need for the methodologies to be streamlined so 
they can be followed using both software 
packages.

QGIS - Introduction



Vector Data

• Vector data is a geographic data type where data is stored as a collection of points, 
lines, or polygons along with attribute data. 

Raster Data

• Raster data is a geographic data type where data is stored as a grid of regularly sized 
pixels along with attribute data. 

GIS basics - Introduction



The LHEES Stage 4 approaches utilising ArcMap have been 
categorized into 7 QGIS groups. 

1. QGIS Set-Up
2. Importing of Layers
3. Attribute Table Related
4. Selection 
5. Vector Processes
6. Raster Processes
7. Symbology

Steps will be walked through using various LHEES Priorities for 
the area of Central St Andrews in Fife.

QGIS - Introduction



Slide Setup:

- Listing of where each task is applicable in each 
LHEES methodology.

- Undertake few Sections then QGIS walkthrough
- Five Demos between seven QGIS Sections

How are we going to run the 
presentation 

Where is this applicable:
• All Stage 4 

Methodologies

Where is this applicable:
• Non-Domestic – (1, 2)
• Heat Networks – (1, 2)
• Off Gas Grid – (1)
• Energy Efficiency – (2)
• Mixed Tenure – N/A
• On Gas Grid – (1)



QGIS Set-Up
• Coordinate System

• Add a Basemap



Set-Up Introduction:

• Steps for opening the QGIS workspace for Stage 4 analysis

• Includes workspace setup (e.g. basemaps, applying 
projections) allows uniformity in the GIS analysis and 
outputs

QGIS – Set-Up



QGIS - Set Up

Coordinate System:
• Open Workspace
• Navigate to “Project Properties – CRS”
• Select “EPSG:27700 – British National Grid”
• Coordinate System is presented in bottom right-

hand corner

Where is this applicable:
• All Stage 4 

Methodologies

Installation of the “QuickMapServices” Plugin may 
be required to get range of basemaps available.

Basemap:
• Various basemaps available for utilisation
• As per Stage 4 methodologies, select “ESRI Topo”



QGIS Importing of Layers
• Import Vector Files

• Import Raster Files

• Import a CSV Files

• Create Geodatabase

• Save Files in a Geodatabase



Importing of Layers Introduction:

• Steps for inputting different data types into a QGIS workspace

• Saving layers within a single, central database for each Stage 4 Methodology. 

• Geopackages improve organization of multiple layers and distribution of files.

QGIS – Importing of Layers



QGIS – Importing of Layers

Import Vector and Raster Files:
• Navigate to Layer -> Add Layer
• Select either Add Vector or Raster Layer
• Click “…” to select File and OK to import into workspace
• Imported Files are shown in Layer Window
• Slightly different for .csv files

Where is this applicable:
• All Stage 4 

Methodologies



QGIS – Importing of Layers
Where is this applicable:
• All Stage 4 

Methodologies

Import CSV Files:
• Navigate to Layer -> Add Layer
• Select “Delimited Text Layer”
• Click “…” to select File
• Ensure to:

• File Format = “CSV”
• Geometry Definition = “Point Coordinates”
• The X and Y Fields correspond to those in the CSV

• Attribute Table Visualised
• Add Dataset



QGIS – Importing of Layers
Where is this applicable:
• All Stage 4 

Methodologies

Geodatabase:
• Creation of ESRI File Geodatabase is unique for ArcMap 

software
• Recommended use of Geopackages (.gpkg) to store 

datasets
• Undertaken once a layer has been imported / created
• Ensure to also save the QGIS Workspace, (.qgz file)

Database name

Layer name within 
Database

Layer Type

Set Coordinate 
System

Database

Layers within 
Database



QGIS – Importing of Layers
Where is this applicable:
• All Stage 4 

Methodologies

Save Files to a Database:
• Right Click a File -> Export -> Save As

• Ensure as a GeoPackage
• Saving within the Database

• Files can also be dragged from the Layers Panel 
into the Database dropdown of the Browser 
Panel

• Temporary layers (Symbolised by      ) are 
generated after some processes, are required 
to be saved, else will be lost after QGIS is 
closed.

Ensure Database

Layer name within 
Database

Save as GeoPackage



QGIS Attribute Table Related
• Copy Attribute Table to Excel

• Creation of Fields

• Field Calculator – Calculation (e.g. LHD)

• Set Max Values (e.g. 250m)

• Delete values from attribute table



Attribute Table Related Introduction:

• Visualizing displayed information on features of a selected vector layer.

• Creating new Fields and perform calculations on attributes. 

• Deleting unused fields / columns.

QGIS – Attribute Table Related



QGIS – Attribute Table Related
Where is this applicable:
• Non-Domestic – (1, 2)
• Heat Networks – (1, 2)
• Off Gas Grid – (1)
• Energy Efficiency – (2)
• Mixed Tenure – N/A
• On Gas Grid – (1)Copy Attribute Table to Excel (1):

• Open Attribute Table (       ) 
• Right Click Layer -> Open Attribute Table

• Select All (CTRL + A)
• Copy (CTRL + C)
• Open Excel
• Paste (CTRL + V)

Creation of Fields (2):
• Open Attribute Table
• Enable Layer Editing (    )
• Add Field (            ) – this won’t populate the field just create one

• OR
• From the Field Calculator (       ) – will simultaneously populate 

field if an expression or value is entered



QGIS – Attribute Table Related

Field Calculator Calculations:
• Open Attribute Table
• Click Field Calculator (       )

1. Unique Zone IDs
• Utilises ‘@row_number’ 
• Ensure Field Type is as Text
• Concat function combines text from multiple strings
• Text within an expression is between single quotation marks ‘   ‘

2. Calculate Area (m2)
• ‘$area’ from “Geometry” Dropdown

3. Field Value Calculations (e.g. LHD)
• Select Fields from “Fields and Values” Dropdown
• E.g. “Annual kWh”
• Combine Fields with calculation
• Fields within an expression once selected are between double 

quotation marks “   “

Where is this applicable:
• Non-Domestic – (3)
• Heat Networks – (1, 2, 3)
• Off Gas Grid – N/A
• Energy Efficiency – (3)
• Mixed Tenure – N/A
• On Gas Grid – N/A



QGIS – Attribute Table Related

Field Calculator Calculations Continued:
• Open Attribute Table
• Click Field Calculator (       )

1. Set Max Values
• Select Values of which to overwrite (e.g. Select by 

Attributes)
• Open Field Calculator
• Ensure to click update selected features only
• Click Update existing field and select the field 

from the dropdown
• Enter in expression box value to overwrite with

2. Delete rows from Attribute Table
• Select Rows / Values to delete
• Enable Layer Editing (    )
• Delete Selected Features (     )

Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – (1, 2)
• Off Gas Grid – N/A
• Energy Efficiency – N/A
• Mixed Tenure – N/A
• On Gas Grid – N/A



QGIS Selection Methods
• Select by Attributes

• Visual Select Tool

• Clear Selection

• Creation, Deletion and Moving Points



Selection Methods Introduction:

• Selecting by attributes (process in the attribute table)

• Selecting by location

• Adding and moving points – particularly useful after internal review

QGIS – Selection Methods



QGIS – Selection Methods

1. Select by Attributes / Expression
• Open Attribute Table of Layer
• Click Select Features Using An Expression (     )
• Insert Expression for Selection

• Using the ‘Fields and Values’ dropdown to select the Field
• These can then be exported as new layer if required

• Right Click Layer -> Export -> Save Selected Features As

2. Clear Selection Button
• Once a Selection has been made, ensure to clear the selection
• So doesn’t affect future processes
• Click Deselect Features (       )

3. Visual Selection
• Click / Select layer in Layer Panel
• Click Select Features by Area (           )

• Click and Drag to Select an Area
• Single Click to Select a Point
• Hold Shift or CTRL to Select more than one Point

Where is this applicable:
• All Stage 4 

Methodologies



QGIS – Selection Methods

1. Adding, Deleting and Moving Point Data 
• Click / Select layer in Layer Panel
• Enable Layer Editing (    )
• Add a Point – Click Add Point Feature (       )

• Click location, set values and OK
• Delete a Point – Select Point

• Click Delete or Delete Selected Features  (     )
• Move a Point – Click Vertex Tool (      )

• Click on Point, Click for new Location
• Ensure to click Enable Layer Editing again to Save Changes

Where is this applicable:
• All Stage 4 

Methodologies



QGIS Vector Processes
• Buffer Tool

• Dissolve Tool

• Clip Tool

• Spatial Join Tool

• Polygon Attributes to Point Data

• Merging of Shapefiles



Vector Processes Introduction:

• Use various vector tools to perform spatial operations – this includes tools from 
different QGIS toolboxes

• How to carry out the analysis on appropriate vector layers – predominately point data 
but also polygon datasets

QGIS – Vector Processes



QGIS – Vector Processes

1. Buffer Tool
• Define areas at specified distances from an object
• Either a set distance e.g. 10 meters
• Or set by a Field Variable e.g. LHD Field
• May automatically Dissolve

2. Dissolve Tool
• Combining adjacent polygons, spatially or by a specified 

attribute
• Input Layer and Run if Spatially Dissolving
• Select “Dissolve Field” if Dissolving by Field Attribute

Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – (1, 2)
• Off Gas Grid – (2)
• Energy Efficiency – (2)
• Mixed Tenure – (2)
• On Gas Grid – (2)



QGIS – Vector Processes

1. Clip Tool
• Input Layer the user would like to clip e.g. Point Data
• Select Overlay which is the boundary to clip by, e.g. 

Certain IZ.

2. Merge Shapefiles
• Used when merging different LHD clusters together into 

one Shapefile
• Select Merge Vector Layers
• Select the layers to merge and the coordinate system

Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – (2)
• Off Gas Grid – (1)
• Energy Efficiency – N/A
• Mixed Tenure – (1)
• On Gas Grid – (1)



QGIS – Vector Processes
Where is this applicable:
• Non-Domestic – (1, 2)
• Heat Networks – (1, 2)
• Off Gas Grid – (1)
• Energy Efficiency – N/A
• Mixed Tenure – N/A
• On Gas Grid – (1)1. Spatial Join Tool

• To calculate Sum, Count and Averages
• Use “Join Attributes by Location (Summary)” Tool

• Polygon is Input, Point data is Join Layer
• Geometric predicate – leave as Intersect
• Choose the field you want to summarise
• Choose mean, and/or any other stats to calculate

2. Polygon Attributes to Point Data
• Use “Join Attributes by Location (Summary)” Tool

• Point Data is Input, Polygon is Join Layer
• Geometric predicate – leave as Intersect
• Choose the field you want to Join



QGIS Raster Processes
• Raster to Polygon Tool

• Raster Calculator

• Raster Extract by Attributes

• Integer Tool

• Point to Raster Tool

• Inverse Distance Weighting Tool

• Raster Weighted Sum Tool

• Standard Deviation



Raster Processes Introduction:

• Converting to and from vector to raster

• Extracting raster values

• Carrying out analysis in the raster Field Calculator

QGIS – Raster Processes



QGIS – Raster Processes

Integer Tool:
• Rounding of Rasters to a whole number integer
• Raster -> Conversion -> Translate (Convert Format)
• Input Raster and select Coordinate System
• Click Advanced Parameters Dropdown
• Select “Int32”
• Int32 is chosen over Int16 due to holding larger 

numerical values

Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – Yes
• Off Gas Grid – Yes
• Energy Efficiency – Yes
• Mixed Tenure – Yes
• On Gas Grid – Yes



QGIS – Raster Processes

1. Raster Calculator
• Search for Tool within Processing Toolbox
• Very similar tool presentation between ArcMap and QGIS
• Ensure to change Cell Size and CRS

2. Raster Extract by Attributes
• No stand-alone tool
• Uses Raster Calculator
• In Expression box insert Layer and use = and/or < , > values to 

Select, e.g. areas over 50 kWh/yr/m2
• Creates areas with 1 or 0
• Convert to Polygon
• Delete areas = 0
• Alternatively for presentation purposes 0 values can be set to 

transparent for visual purposes

Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – (1, 2)
• Off Gas Grid – (2)
• Energy Efficiency – (1)
• Mixed Tenure – (2)
• On Gas Grid – (2)



QGIS – Raster Processes

1. Raster to Polygon Tool
• Use Polygonize Tool
• Input Raster and Band (Field)

2. Point to Raster Tool
• No stand-alone tool to calculate Sum, Count and Average 

when converting to Raster
• Create a Grid – set as Rectangle, Grid extent to be that of 

the Point Dataset and create spacing e.g. 100m by 100m.
• Use “Join Attributes by Location (Summary)” Tool

• Grid is Input, Point data is Join Layer
• Geometric predicate – leave as Intersect
• Choose the field you want to summarise
• Choose mean, and/or any other stats to calculate

• Delete any squares with no data
• Use Rasterize Tool

Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – (N/A)
• Off Gas Grid – (1, 2)
• Energy Efficiency – (1)
• Mixed Tenure – (1, 2)
• On Gas Grid – (1, 2)



QGIS – Raster Processes
Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – N/A
• Off Gas Grid – (3)
• Energy Efficiency – (1, 2)
• Mixed Tenure – (3)
• On Gas Grid – (3)1. Inverse Distance Weighting (IDW) 

• Search for “IDW Interpolation” Tool within Processing 
Toolbox

• Select Layer and Field / Attribute, click Add (green plus)
• Set coefficient to 2.5, pixel size to 100m and extent

2. Raster Weighted Sum Tool
• Not stand-alone tool
• Uses Raster Calculator 
• For Layer 1 (60% weighting), Layer 2 30%, Layer 3 10%:
• In Expression Box

• 0.6*Layer 1 + 0.3*Layer 2 + 0.1*Layer 3
• Set Cellsize, extent and CRS and Click Run

3. Raster Standard Deviation
• Search for “Raster Layer Statistics” within Processing Toolbox
• Input Layer and Run
• Click Results Viewer to view Statistics such as Range, Mean, 

Standard Deviation of Raster Dataset.



QGIS Symbology Related
• Different Types of Symbology

• Graduated Colour

• Colour by Category

• Symbology Classifications

• No. Classes and Range Values

• Sized Points
• Colour and Size Combines

• Shape of Points

• Layer Transparency



QGIS – Symbology Related

To Open the Symbology Window of a Layer:
Right Click Layer -> Properties -> Symbology

Four primary Symbology types:
- Vector - Single Symbol
- Vector - Categorized
- Vector - Graduated
- Raster – Singleband Pseudocolor

Where is this applicable:
• All Stage 4 

Methodologies



QGIS – Symbology Related

Single Symbol:

1. Point Data Size
• Point Size presented.

2. Point Data Shape
• Click “Simple Marker”, Select Shape at bottom

3. Point Data Sized by Value
• Click (    ) next to Size, Field Type and Select 

Field to size by e.g. Heat Demand.

4. Layer Colour
• Click “Simple Marker” and edit “Fill Color”, 

“Stroke Color”, “Stroke Style” and “Stroke 
Width”.

5. Layer Transparency
• Opacity bar presented
• Or click “Layer Rendering”

Where is this applicable:
• All Stage 4 

Methodologies



Categorised: - Unique Value Symbology
Select “Value” Field from dropdown list and click “Classify”

1. Point Data Size
• Click “Symbol” under “Value” to change ALL symbols.
• Click Symbols under Symbol Column to change manually

2. Point Data Shape
• Same as for Data Size

3. Colour by Category and Size combined
• Click “Symbol” under “Value”
• Click (    ) next to Size, -> Assistant
• Select Source / Field and Refresh (    )

4. Layer Colour
• Select Color Ramp from dropdown or “Random Colour”
• And/or Same as for Data Size

5. Layer Transparency
• Click “Layer Rendering”, change Opacity

QGIS – Symbology Related
Where is this applicable:
• All Stage 4 

Methodologies



QGIS – Symbology Related
Graduated: - Used to show numerical quantitative differences
Select “Value” Field from dropdown list and click “Classify”

1. Point Data Size and Shape
• Click “Symbol” under “Value” to change ALL symbols.
• Click Symbols under Symbol Column to change manually
• Change Method present changes in colour or size of symbols

2. Layer Colour
• Select Color Ramp from dropdown 
• Click Symbols under Symbol Column to change individually

3. Colour by Category and Size combined
• Same as for “Categorised”

4. Change no. Classes and Range Values
• Edit No. Classes 
• Double Click Values  in “Value Column” to edit band values.

5. Layer Transparency
• Click “Layer Rendering”, change Opacity

Where is this applicable:
• All Stage 4 

Methodologies



QGIS – Symbology Related
Where is this applicable:
• Non-Domestic – N/A
• Heat Networks – (1, 2, 3)
• Off Gas Grid – (1, 2, 3)
• Energy Efficiency – (1, 2, 3)
• Mixed Tenure – (1, 2, 3)
• On Gas Grid – (1, 2, 3)Raster – Singleband Pseudocolor:

1. Layer Colour
• Select a “Color Ramp” from dropdown menu.
• Manually click Colour within “Color Column” to change.

2. Change no. Classes and Range Values
• Change Mode to “Equal Interval”
• May now edit No. Classes from default locked 5
• Double Click Values  in “Value Column” to edit band 

values.

3. Layer Transparency
• Click “Transprency” in Layer Properties
• Edit “Global Opacity”



ArcMap Task and  QGIS counterpart 
• Table lists all ArcMap tasks referred to within LHEES Methodology 

• Each is categorized and the equivalent QGIS function given. 

• Task symbol in QGIS shown.  

• Notes with short process overview provided.



GIS Task Database (1)

No. ArcMap Task Category QGIS Counterpart Task Symbol Notes

1 Coordinate System Set Up Same Project -> Properties -> CRS

2 Basemap Set Up Same Web -> QuickMapServices -> ESRI -> ESRI Topo

3 Import Vector File Importing Layers Same Layer -> Add Layer -> Add Vector Layer

4 Import Raster File Importing Layers Same Layer -> Add Layer -> Add Raster Layer

5 Import CSV File Importing Layers Same Layer -> Add Layer -> Add Delimited Text Layer
Click CSV -> Point Coordinates -> Set X and Y

6 ArcMap Geodatabase Importing Layers GeoPackage Once layer in workspace. Save as Geopackage.
Set GeoPackage Database name and Layer Name

7 Save to Database Importing Layers GeoPackage Drag into GeoPackage OR 
Save as Geopackage, same Database, set Layer Name

8 Copy to Excel Attribute Table CSV File Export -> Save As -> Comma Separated Value (CSV)

9 Editing Attribute Table Editing Mode In QGIS Digitizing Toolbar OR
Within Attribute Table (AT) -> Enable Editing

10 Add Field Attribute Table New Field Open AT -> Enable Editing -> New Field

Each “ArcMap Task” is listed with the “Category” within this PowerPoint, the “QGIS Counterpart” name 
if different, a “Symbol” for the Task and brief notes on undertaking



GIS Task Database (2)

No. ArcMap Task Category QGIS Counterpart Task Symbol Notes

11 Field Calculator Attribute Table Same Open AT -> Field Calculator

12 Delete Selected Attribute Table Same Open AT -> Enable Editing -> New Field

13 Select by Attributes Selection Method Select by Expression Open AT -> Click -> Create Expression

14 Clear Selection Selection Method Deselect Features In QGIS Selection Toolbar OR Within AT 

15 Select Features Selection Method Same In QGIS Selection Toolbar

16 Create Features Selection Method Add Point Feature Enable Editing -> In QGIS Digitizing Toolbar

17 Edit Vertices Selection Method Vertex Tool Enable Editing -> In QGIS Digitizing Toolbar

18 Delete Feature Selection Method Delete Selected Enable Editing -> Select Feature -> Click or DELETE

19 Buffer Vector Processes Same Vector -> Geoprocessing -> Buffer

20 Dissolve Vector Processes Same Vector -> Geoprocessing -> Dissolve

21 Clip Vector Processes Same Vector -> Geoprocessing -> Clip

22 Merge Vector Processes Merge Vector Layers Vector -> Data Management -> Merge Vector Layers



GIS Task Database (3)
No. ArcMap Task Category QGIS Counterpart Task Symbol Notes

23 Spatial Join Vector Processes Join Attributes by 
Location (Summary)

Search for tool within Processing Toolbox 
(Processing -> Toolbox)

24 Int (Spatial Analyst) Raster Processes Translate (Convert 
Format)

Raster -> Conversion -> Translate (Convert Format)

25 Raster Calculator Raster Processes Same Search for tool within Processing Toolbox 

26 Extract by Attributes Raster Processes Raster Calculator Search for tool within Processing Toolbox 
(Processing -> Toolbox) -> Convert to Polygon & 
Delete unsuitable values or alter Symbology

27 Raster to Polygon Raster Processes Polygonize Raster -> Conversion -> Polygonize 

28 Point to Raster Raster Processes Rasterize Raster -> Conversion -> Rasterize
To Get Statistics also -> Create Grid -> Join Attributes 
by Location -> Rasterize

29 Inverse Distance 
Weighting (IDW) 

Raster Processes IDW Interpolation Search for tool within Processing Toolbox 

30 Weighted Sum Raster Processes Raster Calculator Search for tool within Processing Toolbox 

31 Standard Deviation Raster Processes Raster Layer 
Statistics

Search for tool within Processing Toolbox 
(Processing -> Toolbox)



GIS Task Database (4)
No. ArcMap Task Category QGIS Counterpart Task Symbol Notes

32 Single Symbol Symbology Same Right Click -> Symbology -> Single Symbol
Set Size
Size by Value -> Click ‘Data Defined Overide’       -> 
Field Type -> Select Field
Simple Marker -> Set Shape, Fill and Stroke Colours
Layer Rendering -> Transparency

33 Categories Symbology Categorized Right Click -> Symbology -> Categorized
Click Main Symbol -> Set Size and Shape
Click Individual Symbols -> Set Colours
Size by Value -> Click Main Symbol -> ‘Data Defined 
Overide’       -> Assistant -> Select Field
Layer Rendering -> Transparency

34 Quantities Symbology Graduated Right Click -> Symbology -> Graduated
Click Main Symbol -> Set Size and Shape
Set Colour ramp
Set no. Classes and Range Values
Layer Rendering -> Transparency

35 Raster Classified Symbology Singleband
Pseudocolor

Right Click -> Symbology -> Singleband Pseudocolor
Set Colour ramp
Set no. Classes and Range Values
Layer Properties -> Transparency


