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1 Introduction 

Technical Guidance Note 2 provides an overview of your options in instances where your vector data 

is the wrong type (i.e. instead of polygons, your data is point or line). There will often be a number of 

options for dealing with this data and some judgement will e required depending on the situation. 

2 Preparing Vector Data 

2.1 Point Data 

First identify whether the point data is captured by an existing layer. The ‘Select by Location’ tool can 

be used to check this (Vector > Research Tools > Select by Location).  

It is important that the ‘Include input features completely within the selection features’ checkbox is 

ticked.  The ‘intersect’ checkbox should not be used, as it would capture adjacent features. 

 
 

Once you have run ‘Select by Location’ open the ‘Attribute Table’ to check how much of the dataset is 

selected (Figure 1). 

 

 

Where none of the points are captured by the existing polygon layers, there are two options: 

 Create a new polygon layer and manually digitise the boundaries; or 

Figure 1: Example results from the Select By Location Tool. In this example 44 of the 65 points 
fall within the existing polygon layer 



 Manually digitise the boundaries to an existing layer.  

Manually digitising the boundaries to an existing layer provides a better basis for the division process 

but should only be considered if it does not impact on your ability to accurately zone your land. 

If the points do fall within an existing layer, you must consider whether the information within the point 

layer justifies creating a new layer (i.e. does the information in the points layer contribute towards the 

zone category of the polygon).  

If the point data represents ‘Potential Litter Sources’ listed in Tables 2 and 3 of the ‘Zoning: 

Introductory Guidance Note’, consider whether the information could be used in the current form to 

assist with the zoning process (see Technical Guidance Note 3, Utilisation of Non-Domestic Rates 

Registers). 

Please note that polygon layers should not overlap. If a new layer is being created on top of an 

existing one, it should be cut from the existing layer. The geoprocessing tool ‘Difference’ can be used 

to cut the new layer from the existing layer (Vector > Geoprocessing Tools > Difference). See 

Technical Guidance Note 1; section 4.2. 

Snapping tolerances should be used when mapping the new features to avoid issues when cutting 

from the existing layer (i.e. to avoid slivers and fragments of land where the boundaries don’t match). 

See Technical Guidance Note 1; section 4.1. 

2.2 Line Data 

2.2.1 Lines Used As Boundaries 

Two tools may be useful where lines have been used in place of polygons to map boundaries: 

 Lines to Polygons 

 Polygonize 

The ‘Lines to Polygons’ tool is accessed via Vector > Geometry Tools > Lines to Polygons. The tool 

works well on simple data and appears less sensitive than the Polygonize tool in respect to lines not 

intersecting or sharing common vertices. Self-intersecting lines will lead to unwanted results. 

The ‘Polygonize’ tool is accessed via Processing > Toolbox > search for Polygonize. This tool will not 

work if lines do not intersect or have shared vertices. It will also produce unwanted results if there are 

self-intersecting lines. 

Extensive sense checks would be required if either of the above tools were used. 

To avoid errors the most effective method is creating a new polygon layer and using the ‘Trace’  

tool from the ‘Advanced Digitizing Toolbar’. Remember to set appropriate snapping options prior to 

undertaking the task (see Technical Guidance Note 1; section 4.1). 

 

2.2.2 Lines Used to Mark Roads 

The following section details a methodology for converting Local Authority road datasets that are of 

the wrong data type for the Polygon Divider (i.e. lines instead of polygons). 

The process makes a number of assumptions: 

 Local Authorities have licenses for OS MasterMap Topography; 

 The MasterMap data is of the highest quality; and 

 The Local Authority line data is good quality and matches up (or can be adjusted to match up) 

with the MasterMap roads. 
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2.2.2.1 MasterMap Topography 

The ‘MasterMap Topography - Topographic Area’ layer (henceforth referred to as MM Topo Area) is 

extremely large (particularly in built up areas). Consequently, it may be worth clipping the data into 

manageable sized sections before proceeding.  

2.2.2.1.1 Separating Data By Grid Square 

The process for clipping the ‘MM Topo Area’ data into manageably sized sections is: 

 Load the ‘MM Topo Area’ layer; 

 Load the OS Grid Square layer (this example uses 1km grid squares due to the highly built up 

nature of the location. It is anticipated that larger grid squares could be used in more rural 

areas); 

 Select the grid squares you want to clip: 

 

 

 Navigate to Vector > Geoprocessing Tools > Clip; 

 The ‘Input vector layer’ is the ‘MM Topo Area’; 

 The ‘Clip layer’ is the grid layer; 

 Make sure to check the ‘Use only selected features’ checkbox; 

 Browse to where you want the ‘Output shapefile’ to be saved: 
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 You should now have a layer just covering the selected grid squares: 

 

 

2.2.2.2 Separating Data By Road Feature 

Now that the data is a more manageable size, it can be manipulated by creating a new layer that 

includes features solely relating to roads (‘Road Features’).  This is done by: 

 Identify what features relate to roads (this is likely to vary depending on the clipped area); 

 Left click on your newly clipped layer in the ‘Map Legend’; 

 Click on the ‘Select features using an expression’  button in the top toolbar; 

 In the dialog box, expand the ‘Fields and Values’ list and double click on ‘descriptiv’; 

 Type ‘IN’; 

 Open brackets; 

 Click on ‘all unique’ and double click on the values relating to roads, making sure to separate 

each value with a comma;  

 Close brackets; 

 Click on ‘Select’ once the expression is complete: 

 

 



 

 Close the dialog box; 

 Right click on the layer in the ‘Map Legend’ and select ‘Save As…’; 

 Browse to where you want the new layer to be saved; 

 Make sure CRS is British National Grid; 

 Important: Check the ‘Save only selected features’ Checkbox; 

 Click ‘OK’: 

 

 
 

 You should now have a layer just showing ‘Road Features’: 
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2.2.2.3 Creating Polygon Data for Roads 

2.2.2.3.1 Creating Polygon Data for Roads 

The first step is to create a new layer that captures only the roads that Local Authorities own (‘LA 

Roads Only’) by: 

 Right click on the ‘Road Features’ layer in the ‘Map Legend’ and click on ‘Filter…’; 

 Double click on ‘descriptiv’ in the ‘Fields’ section of the window; 

 Click on = in the ‘Operators’ section of the window; 

 Click on ‘All’ in the ‘Values’ section of the window and double click on ‘(1:Road Or Track)’; 

 Click ‘OK’: 

 

 

 The ‘Road Features’ layer has now been filtered to include only roads; 

 Use the research tool ‘Select by Location’ to select all of the roads that are intersected by the 

Local Authority line dataset (LA Line); 

o Vector > Research Tools > Select by Location: 



 
 

o ‘Seect by location’ results should look similar to: 

 
 

o Save as a new layer called ‘LA Roads Only’: 
 Right click on the ‘Road Features’ layer in the ‘Map Legend’ and select ‘Save 

As…’; 

 Important: Save the layer in a newly created folder called ‘Merge’; 

 Make sure CRS is British National Grid; 

 Important: Check the ‘Save only selected features’ Checkbox; 

 Click ‘OK’: 
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2.2.2.3.2 Creating A Layer for Roadside Features 

A layer should now be created that captures any roadside features (‘Not Roads’). To do this: 

 Right click on ‘Road Features’ in the ‘Map Legend’ and click on ‘Filter…’; 

 Click on ‘Clear’ to remove the previous filter; 

 Double click on ‘descriptiv’ in the ‘Fields’ section of the window; 

 Click on != in the ‘Operators’ section of the window; 

 Click on ‘All’ in the ‘Values’ section of the window and double click on ‘(1:Road Or Track)’; 

 Click ‘OK’: 

 

 

 The ‘Road Features’ layer has now been filtered to include only features that are not roads or 

tracks: 



 
 

 Save as a new layer called ‘Not Roads’: 
o Right click on the ‘Road Features’ layer in the ‘Map Legend’ and select ‘Save As…’; 

o Important: Save the layer in the ‘Merge’ folder; 

o Make sure CRS is British National Grid; and 

o Click ‘OK’. 

 

2.2.2.3.3 Merge ‘LA Roads’ and ‘Roadside Features’ Layers 

Now merge the ‘LA Roads’ and the ‘Not Roads’ layers. Both of these layers should have been saved 

in a folder called ‘Merge’ and as such the process is as follows: 

 Vector > Data Management Tools > Merge Shapefiles to One: 

 

 
 

 The ‘Input directory’ is your ‘Merge’ folder. 

 Save the ‘Output shapefile’ as ‘Roads Combined’ 

 

2.2.2.3.4 Spatial Join Between LA Line and Merged Datasets 

We now want to insert the attribute data from the Local Authority Line dataset into the ‘Roads 

Combined’ dataset.  This is done using a ‘Spatial Join’, the process is as follows: 

 Vector > Data Management > Join Attributes by Location; 
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 The ‘Target vector layer’ is ‘Roads Combined’; 

 The ‘Join vector layer’ is ‘LA Line’; 

 Save the ‘Output Shapefile’ as ‘Roads Combined SJ’; 

 Make sure ‘Keep all records (including non-matching target records)’ is selected in the ‘Output 

table’ 

 Click ‘OK’:  

 

 

The ‘Attribute Table’ should now include attributes from both the ‘Roads Combined’ and ‘LA Line’ 

layers.  It is recommended that you delete any unwanted fields from the ‘Attribute Table’. 

 

2.2.2.3.5 Buffer LA Line Dataset 

The next step of the process involves buffering the Local Authority line data (‘LA Line’) to a width that 

captures the road and any roadside features owned by the Local Authority. The buffer will be used 

later to clip the ‘Roads Combined SJ’ layer (i.e. to create a polygon layer that only contains road 

features owned by the Local Authority): 

 



 

This example uses a fixed buffer distance though there may be instances where using a variable 

buffer provides better results (i.e. different sized buffers could be used for different classes of road). 

The optimum buffer size is dataset and site specific, and as such you may need to trial a number of 

buffer sizes to find the best match to the data. It is important to do this as accurately as possible, so as 

to minimise the amount of manual work required at the end of the process. 

The following details how to buffer the ‘LA Line’ data: 

 Vector > Geoprocessing Tools > Buffer(s): 

 

 

2.2.2.3.6 Use the Buffer Layer to ‘Clip’ the Combined Layer 

We now want to use the buffer layer to clip the ‘Roads Combined SJ’ Layer by by: 

 Vector > Geoprocessing Tools > Clip: 

 
 

 Save the ‘Output shapefile’ as ‘LA Roads Polygon’; 

 You now have a polygon layer that largely represents your land ownership: 
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2.2.2.4 Manual Adjustments 

The above process will accurately capture the majority of the Local Authority road features. However, 

the variable nature of roadside features ensures that there will always be some areas that require 

manual adjustments before the layer can be finalised. 

Adjustments will be required to address locations: 

 Where Local Authorities do not own or have responsibility for the roadside feature; 

 Where the buffer has been too large (i.e. roadside features that have not been fully clipped by 

the buffer and therefore require manual removal: 

 
 Where the buffer has been too small (i.e. roadside features which have been clipped when 

they shouldn’t have been (Figure 9)); 



  

 

2.2.2.4.1 Identification of Features 

The first step is to identify where manual adjustments are required: 

 This is a visual process.  Therefore, it is important to consider the styles of the layers and their 

order in the ‘Map Legend’: 

 

 

 It is useful to use contrasting colours for the ‘LA Roads Polygon’ and the ‘Roads Combined 

SJ’ layers as this will help identify Local Authority land that has been clipped where the buffer 

is too small. This is expected to occur where roadside features are larger than average (e.g. 

roundabouts); 
 Many cases of roadside features being included where they should not may be at junctions to 

private roads. These should be relatively easy to identify. There will also be cases where the 

Local Authority own the road but not the roadside feature. 

 

2.2.2.4.2 Removal of Features 

The process for manually removing features is as follows: 

 Left click on the ‘LA Roads Polygon’ in the ‘Map Legend’; 

 Make the layer ‘Editable’ ; 

 Select the ‘Split Features’  tool from the ‘Advanced Digitizing Toolbar’; 

 Draw lines where you want to create the split. (Note: the start and end clicks should be outside 

of the polygon. This example uses black circles to show the start and end clicks when splitting 

the feature: 



Zoning: Technical Guidance Note 2: Preparing Vector Data 
 

17 

 

 

 Use a manual selection tool  to select the area you want to delete: 

 

 

 Click on the delete button to remove the selected area; and 

 Save the layer edits . 

 

 



2.2.2.4.3 Adding Features 

The process for adding Local Authority features that have been removed as result of the buffer being 

too small are as follows: 

 Set the ‘Advanced Snapping Options’ via Settings > Snapping Options: 

 
 

o Left click on the ‘LA Roads Polygon’ in the ‘Map Legend’. 

o Make the layer ‘Editable’ . 

o Select the ‘Node’ tool . In the example below the blck circle illustrates the selected 

node 

 

 
 

o Delete or move nodes: 

 

 

 Save the layer edits . 
 Note: in instances where deleting or moving nodes is impractical, a new feature can be drawn 

.  The ‘Trace’ tool  could be used to speed up this process.  



Zoning: Technical Guidance Note 2: Preparing Vector Data 
 

19 

 


