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1. Introduction

Local Authority land ownership and areas of responsibility are not static. Therefore, it is necessary to
periodically update the zoning layers to reflect any changes. It is important when making these
changes, that the unique identifiers associated with unchanged land are not affected.

Technical Guidance Note 6 provides a step-by-step guide to updating zoning layers in future years..

2. The Process
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Figures 1 and 2 provide a simple example to demonstrate the process:

Figure 1: Survey areas 2017 (herefter referred to as '2017")

Figure 2: Land ownership / responsibility 2018 (hereafter referred to as '2018 Boundary")

Changes since the 2017 assessment have been highlighted as follows:

e Ared square has been used to highlight where land has been sold; and

e A black square has been used to highlight where further land has been acquired.

These changes to the land boundary need to be reflected for the 2018 survey areas.



2.1. Removal of Sold Land

The first step is to create a layer that represents land that you are no longer responsible for
(henceforth referred to as sold). If you already have such a layer skip to Paragraph 2.8.

2.1.1. Creating A ‘Sold’ Layer

To create the ‘Sold’ layer you need to cut the 2018 Boundary’ layer from the ‘2017’ layer. The process
is as follows:

e Vector > Geoprocessing Tools > Difference
¥ Difference ? *

Input vector layer
2017 M |

(] Use only selected features
Difference layer

§2015 Boundary M |

(] Use only selected features

Cutput shapefile

I I Browse

Add result to canvas

0% Close

2.1.2. Removing Sold Land

The removal of land that has been sold involves cutting the ‘Sold’ layer from the 2017’ layer. The
process is as follows:

e Vector > Geoprocessing Tools > Difference:
¥ Difference ? >

Input vectar layer
2017 hd

[] use only selected features

Difference layer

[] use only selected features

Output shapefile

——

Add result to canvas

0% oK Close

e Important: Create a sub-folder called ‘merge’ and save the ‘Output shapefile’ there.
e You now have a layer (‘2017 Sold’) that takes into account the land that has been sold:
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2.2. Adding Newly Acquired Land

The next step is to create a layer that represents land that has been acquired since the 2017 survey
areas were created (hereafter referred to as ‘Acquired’). If you already have such a layer skip to
Section 2.2.2.

2.2.1. Creating An ‘Acquired’ layer

To create an ‘Acquired’ layer you need to cut the ‘2017 Sold’ layer from the ‘2018 Boundary’ layer.
The process is as follows:

e Vector > Geoprocessing Tools > Difference
/' Difference ? *

Input wector layer

2018 Boundar -

[ ] use only selected features

Difference layer

2017 Sold ol

[] use only selected features

COutput shapefile

Add result to canvas

0% Close

2.2.2. If An ‘Acquired’ Layer Already Exists

If you have just created an ‘Acquired’ layer you can skip to Section 2.3.



It is important that your ‘Acquired’ layer doesn’t overlap the 2017 Sold’ layer. Therefore it is
recommended you cut the ‘2017 Sold’ layer from the ‘Acquired’ layer before proceeding.

The process is as follows:

e Vector > Geoprocessing Tools > Difference

7 Difference ? *

Input vector layer
Nacquired

M |

[ use only selected features
Difference layer

fl2017 50ld

[ Use only selected features

Qutput shapefile

| l Erowse
Add result to canvas

o% ose

2.3. Buffering ‘Acquired’ Land to Om

To ensure more uniformly shaped survey areas, the ‘Acquired’ layer should be buffered to Om. This

should dissolve the layer and have the additional benefit of removing a lot of the errors (further details
on dissolving/buffering are provided in Zoning: Technical Guidance Note 4).

The process is as follows:

e Vector > Geoprocessing Tools > Buffer(s):

/. Buffer(s) ? ¥
Input vector layer

IAcquired - I
[] use only selected features

Segments to approximate |60 = |
(®) Buffer distance ID I

(") Buffer distance field
id
EDissolve buffer results
Output shapefile

I I I Browse

Add result to canvas

0% OK Close

2.4. Dividing ‘Acquired’ Land

The newly buffered acquired land (‘Acquired B’) can now be divided using the ‘Polygon Divider’.
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The process is as follows:

e Click on the ‘Polygon Divider’ button 7 in the top toolbar (or select from the ‘Plugins’
pulldown menu):
/" Polygon Divider ? X
Input Layer
hcquirEdB vI
Qutput File

Target Area (in CRS Units)

fi000 |

Cut Direction

I left to right - I

E.ﬂbsorb Offcuts

Further details on the ‘Polygon Divider’ are provided in Zoning: Technical Guidance Note 4.

2.5. Spatial Join

Please note: This step is only required if you have dissolved or buffered your ‘Acquired’ layer prior to
dividing it.
Before performing the ‘Spatial Join’, it is important that any fields relating to the original undissolved

‘Acquired’ layer are removed. This is to ensure the joined layer doesn’t have duplicates that impact the
prescribed attribute naming conventions.

The process for deleting fields from the ‘Attribute Table’ is as follows:
e Left click on the divided layer in the ‘Map Legend’;
e Click on the ‘Attribute Table’ button on the top toolbar;
e Make the layer editable ¥ ;

e Click on the delete fields button *';
e Select the layers you want to delete from the dialog box and click ‘OK’;
e It may take a few minutes if you are deleting a number of fields from a large database; and

e Save the changes rj and stop the layer from being editable v
The only fields remaining after the above process should be:

Poly ID;
Unique_ID;
Area;
PointX; and
PointY.

The ‘Spatial Join’ process is as follows:



e The ‘Spatial Join’ tool is accessed via Vector > Data Management Tools > Join Attributes by
Location;

The ‘Target vector layer’ is the divided polygon;

The ‘Join vector layer’ is your original undissolved/unbuffered ‘Acquired’ layer;

Browse to where you want to save the new layer;

Important: Change the ‘Output table’ from the default position to ‘Keep all records (including
non-matching target records)’;

¢ Click 'OK’;

# Join attributes by location ? *

Target vector layer

IDi\tided Polygon - I
Join vector layer
IAoquired - I

Attribute Summary

E) Take attributes of first located f'eamrel
() Take summary of intersecting features

Mean Min Max Sum Median

Cutput Shapefile

I I Browse
Output table

() Only keep matching records

I (® Keep all records (induding non-matching target records)l

0% Close

2.6. Attribute Table

Any unwanted or duplicate fields should be deleted ' from the ‘Attribute Table’. The exact fields
that should remain:

Org;

Ward;
Identifier;
Zone;
H_and_S;
Reason;
Poly_ID;
Unique_ID;
Area;
PointX; and
PointY.

2.7. Removing Locations With Health & Safety or Access Issues

The next step is to remove any new survey areas that have H&S or access issues.
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The process is as follows:
e Left click on the layer in the ‘Map Legend’;

e Click on the ‘Select features using an expression’ a button in the top toolbar;

¢ Inthe dialog box, expand the ‘Fields and Values’ list and double click on ‘h_and_s’;
e Type: IS NOT;

e Click on the ‘all unique’ button and double click on Y’ in the box above;

e The dialog box should look like this:

7 Select by expression ? X

Expression Function Editor

EEEIEE M D] [ser group Field =
Color A | | Double click to add field name to expression string.
Conditionals Right-Click on field name to open context menu
Conversions sample value loading options.
Date and Time
o [ET— Notes
POLY_ID A
NULL N
UNIQUE_ID Values ‘,-71 «
:gf:'rx NULL
POINTY
org
ward
identifier
zone
< > reason
Fuzzy Matching v Load values 10 samples

Qutput preview: 1

e Click on the ‘Select’ button on the bottom right of the dialog box:

e Close the dialog box:

¢ Right click on your layer in the ‘Map Legend’ and select ‘Save As...’;
e Important: Save file to the ‘Merge’ sub-folder;

e Make sure the CRS is British National Grid;

¢ Important: Check the ‘Save only selected features’ checkbox;

e Click 'OK’:

/' Save vector layer as.. ? x
Format | ESRI Shapefile -
saveas|| || Browse
cRs  ||selected CRS (EPSG: 27700, OSGB 1936 / British National Grid) - i_]
Encoding System -
[Blsve oniy selected features

Skip attribute creation
% Add saved fle tomap

Symbology export No symbology -
Scale 1:50000 =)
v Geometry

Geometry type Automatic -

[ Force multi-type

[ Include z-dimension

» Extent (current: layer)
¥ Layer Options
RESIZE |NO -

SHPT | <Default> -

P Custom Options



2.8. Merging Shapefiles

The next step is to merge the previously created 2017 Sold’ layer to the layer you have just created.

Both layers should have been saved in the ‘Merge’ sub-folder. The process is as follows:

e Vector > Data Management Tools > Merge Shapefiles to One:
# Merge shapefiles ? X

[] select by layers in the folder

Shapefile type Polygon -
Input directory

I I Browse
Output shapefile

I I Browse

Add result to map canvas

0%
0%
Close

e The ‘Input directory’ is the ‘Merge’ folder.

You now have a divided layer, that takes into account the sold and acquired land (Figure 4).

Figure 3: Merged layers
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2.9. Refining Survey Area Size

The process of removing and adding sections of land may have resulted in the creation of survey
areas that are smaller or larger than required. Therefore, we need to refine the size of the survey
areas within the merged layer (‘2018 M’) so that only those with an area between 800m?2 and 1200m?
are included.

The process for refining the survey areas is as follows:
e Leftclick on your 2018 M’ layer in the ‘Map Legend’;

e Click on the ‘Select features using an expression’ & button in the top toolbar;
e In the dialog box, expand the ‘Geometry’ list and double click on ‘$area’:
o Type: > 800 AND $area <1200
o lItis important that you do not use “Area” from ‘Fields and Values’.
e Click on the ‘Select’ button at the bottom right of the dialog box:
7 Select by expression - 2018 M ? X

Expression Function Editar

EEEIAEIFEM D] [ser

farea >800 AND Sarea <1200 I Color # | | Returns the area of the current feature. The area
Conditionals calculated by this function respects both the current
Conversions project's elipsoid setting and area unit settings. Eg, if
Date and Time an elipsoid has been set for the project then the
Fields and Values calculated area will be ellipseidal, and if no elipsoid is
Fuzzy Matching set then the calculated area will be planimetric.
epera

Sarea

bounds

bounds_height
bounds_width * Farea— 42
buffer

centroid

closest_paint

“ > combine

contains W

Qutput preview: 1

£ Select Close

e Close the dialog box.

Figure 4: Survey areas of defined area that have been selected (yellow)



e Right click on your merged layer (2018 M) in the ‘Map Legend’ and select ‘Save As...’;
e Browse to where you want the new layer to be saved;
e Make sure the CRS is British National Grid;
¢ Important: Check the ‘Save only selected features’ checkbox;
e Click ‘OK’:
/' Savevector layer as... ? X
Format | ESRI Shapefile -
Save as I I Browse
RS [|Selected CRS (EPSG:27700, OSGB 1936 / British National Grid) ME |
Encoding System -
ESave only selected features

Skip attribute creation
% Add saved file to map

Symbology export Mo symbology -
Scale 1:50000 '%]
¥ Geometry

Geometry type Automatic -

[ Force multi-type

[ tndude z-dimension

> Extent (current: layer)
¥ Layer Options
RESIZE | NO -

SHPT | «Default= -

P Custom Options

You now have a layer (‘2018’) that represents the 2018 survey areas (see Figure 6). In other words, a
layer that maintains the previously assigned survey areas and accounts for the subsequent changes in
land ownership.
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Figure 5: '2018' survey areas

2.10.  Snapping to Adjoining Polygons

Finally, there may be instances where there are unnecessary gaps between sections of newly
acquired land and existing survey areas. Where this occurs, the snapping tolerances should be set
(see Zoning: Technical Guidance Note 1), the layer should be made editable, and the polygons
snapped together.

Once the adjustments have been made, the ‘Topology Checker’ should be used to make sure no
overlaps have been created (See Zoning: Technical Guidance Note 3).

The process of updating the zoned layer is now complete.



Zero Waste Scotland is a registered company in

o 01786 433930 o zerowastescotland.org.uk o @ZeroWasteScot Scotland (SC436030). Registered office: Ground Floor,
Moray House, Forthside Way, Stirling FK8 10Z



